BLOG zzy.my

合抱之木, 生于毫末; 九层之台, 起于累土; 千里之行, 始于足下。

Win8 / Wi10 / Win11 离线安装 Framework 3.5 离线安装包

2022年4月 已更新 Windows 11 / 10 所有版本 和 Server 2016、2019、2022

Windows 10 正式版切记勿安装 1.6 版本

更新说明

2022.4
添加支持 Windows 11(21H2), 及 Win10 所有版本.
上一版本是2015年写的,发现只能支持 Win10 1709以下版本
最近疫情在家里更新了一下,支持目前 Win10 所有版本,以及 Server 2016/2019/2022
原版Windows镜像提取,新采用7zip压缩,仅37M。无32位系统版本.

 

2015.4
添加支持 Windows 10,(废弃1.6版本)

2014.3
添加支持 Windows 8.1

2013.8
Windows 8 默认没有集成安装 Framework 3.5, 且安装需要在线安装 (-.-!)
好多之前写的程序都无法直接运行.
好吧,至少我觉得应该有种方法可以在没有网络和网速较低情况下的安装方法。
通过Google找到了这样的方法。首先需要有安装光盘或原始安装文件(目录中的sources\sxs)

以管理员权限运行CMD

执行“dism.exe /online /enable-feature /featurename:NetFX3 /Source:G:\sources\sxs”  

其中/Source: 是Win8安装目中的文件夹  

 

 

为了更简单安装它,我制作了一个离线安装包

Windows 8 .NET Framework 3.5 离线安装包,压缩后仅有82M

而且全自动安装,方便携带..

 

注意!警告!

 Windows 8/8.1 中.NET Framework 是区分系统版本和语言的

★ 本集成包使用将原版镜像提取。

 采用高无损压缩

 

提示: 查看自己系统是否已安装 .NET 3.5/2.0 ,
控制面板 - 程序和功能 - 右侧的“打开或关闭Windows功能” 

查看 “.NET Framework 3.5” 是否被勾选

 

文件 最新版本 支持系统 支持语言 大小 更新日期
Win8_Net3.5_x86  1.2.0.1384 Windows 8 32位  中(繁)、英  47M  13/8/4
Win8_2012_Net3.5_x64  1.2.1.13823 Windows 8 64位  中(繁)、英  85M  13/8/23
Win8.1_Net3.5_x86_x64  1.5.0.14320 Windows 8.1 32 & 64 位  中(繁)、英  133M  14/3/20
Win10_Net3.5_x86  1.7.15.1206 Windows 10 32位 (1709及以下)  All  37M  15/12/6
Win10_2016_Net3.5_x64  1.7.15.1206 Windows 10 64位 (1709及以下)  All  69M  15/12/6
Win10&11_Net3.5_x64  1.8.22.418 Windows 11 64位
Windows 10 64位 (ALL)
Server 2016/2019/2022
 All  37M  22/4/18

 

文件 MD5
Win8_Net3.5_x86 b4385add5d721ec77df7f7585fd28c07
Win8_2012_Net3.5_x64 da94136063ec38d00cfe016ad266c089
Win8.1_Net3.5_x86_x64 b8b588a5410c27a6c57f6a211a3927b0
Win10_Net3.5_x86 0cb7c161549c1a7e125f1eb243445f0f
Win10_2016_Net3.5_x64 78918a0b150b90ebbcdf38a7a74abacd
Win10&11_Net3.5_x64 5a8f3284632147597048338fa8f13960

 

Windows 10 正式版切记勿安装 1.6 版本
否则得恢复系统 或 重装系统了;

下载地址:

http://pan.baidu.com/s/1dD0KKAP

 

评论 (38) -

  • Speed乄Jay

    2024-02-23 09:23:11 | 回复

    win11 23H2能支持吗?

  • 小白豆豆

    2022-05-16 11:31:31 | 回复

    大佬你好,今天从百度net3.5搜到华军下载了,版本是1.7.15.1206,系统版本是20h2,安装成功,装好点的关于看到您的提示,不知道有啥影响没

    • zzy

      2024-01-24 22:07:19 | 回复

      提示成功就没问题

  • pawpaw

    2021-03-04 18:42:40 | 回复

    报错如下方,电脑环境比较特殊,无法重装系统无法联网,跪求解决方法

    .NET Framework 3.5 准备安装...
    系统版本: 10.0.18362.1
    安装版本: 10.0.18363.592
    开始安装...

    遇到错误!
    很可能是安装程序与���当前系统不匹配, 或重启后再检查.
    支持的版本为:
    Windows 10 x64位
    Error: 0x800f081f

    • zzy

      2021-03-04 22:39:42 | 回复

      你的操作系统详细版本,以及使用安装包的版本

      • pawpaw_love

        2021-03-08 13:50:24 | 回复

        抱歉这两天忙得头脚倒悬,忘记回复了

        windows 10 家庭中文版
        版本号 1909
        Microsoft Windows [版本 10.0.18363.592]

  • 打发时光

    2020-04-13 22:54:30 | 回复

    下载完成,实验中

  • kukulza

    2020-03-25 11:02:08 | 回复

    .NET Framework 3.5 准备安装...
    系统版本: 10.0.18362.1
    安装版本: 10.0.18363.720
    开始安装...

    遇到错误!
    很可能是安装程序与你当前系统不匹配, 或重启后再检查.
    支持的版本为:
    Windows 10 x64位
    Error: 0x800f081f

  • echoccc

    2020-03-18 12:17:32 | 回复

    安装成功了两次, 非常感谢. 另外,好像安装之前把 windows update 服务 打开更好.

  • bo

    2019-09-26 10:13:24 | 回复

    请大大帮忙看看,是哪里的问题,WIN10 1903版本

    .NET Framework 3.5 准备安装...
    系统版本: 10.0.18362.1
    安装版本: 10.0.18362.239
    开始安装...

    遇到错误!
    很可能是安装程序与你当前系统不匹配, 或重启后再检查.
    支持的版本为:
    Windows 10 x64位
    Error: 0x800f081f

  • foxfirefox

    2019-08-22 13:01:00 | 回复

    .NET Framework 3.5 准备安装...
    系统版本: 10.0.18963.1000
    遇到错误!
    很可能是安装程序与你当前系统不匹配, 或重启后再检查.
    支持的版本为:
    Windows 10 x64位
    Error: 50

  • snailz

    2019-02-01 18:59:40 | 回复

    安装好慢,感觉可能是因为没长期更新,需要的版本没找到???,时间够我下个镜像再离线安装了,翻文件发现我只保留了esd文件 崩溃

  • 张玉建

    2018-07-31 14:53:40 | 回复

    安装时有台电脑提示错误,错误码13,提示请重启后再检查。

  • 翔鹰

    2017-10-21 17:31:47 | 回复

    非常感谢您制作的自动安装net 3.5工具,帮了我大忙了!我试过网上用命令的,用安装包的,都不行。最后才找到您做的软件!一下就搞定了!非常感谢!

  • azxcvbnmazx

    2017-01-16 17:35:01 | 回复

    感谢制作分享,微软的渣渣服务器真的很无语。

  • LHR

    2016-12-28 10:16:03 | 回复

    请问不需要的时候如何卸载?

  • dapeng

    2016-12-06 20:26:56 | 回复

    请问有没静默安装的版本,或者有没有安装参数。

  • 强锅锅

    2016-10-17 13:01:28 | 回复

    解决了,非常感谢

  • 2016-04-02 15:34:35 | 回复

    .NET Framework 3.5 准备安装...
    系统版本: 10.0.10240.16384
    安装版本: 10.0.10240.16384

    就没有别的了,我用dism也是这样。为什么呢

    • zzy

      2016-04-05 14:56:03 | 回复

      重装系统,或者恢复系统,并使用最新版(至少1.7.15.1206)安装

  • newbie

    2016-02-14 01:47:57 | 回复

    你好,用你的离线安装包非常方便,太感谢了。不过有个小疑问,因为有批量部署的需要,所以不知道你的离线包有没有静默安装参数啊,要是有的话就更好了。

  • Birdk

    2015-11-22 09:50:16 | 回复

    谢谢分享,待我回去试试看看好不好用。

  • qzy

    2015-08-04 20:14:46 | 回复

    .NET Framework 3.5 准备安装...
    系统版本: 10.0.10240.16384
    安装版本: 10.0.10240.16384
    开始安装...

    遇到错误!
    很可能是安装程序与你当前系统不匹配, 或重启后再检查.
    支持的版本为:
    Windows 10 x64位

  • hsl

    2014-12-18 19:55:26 | 回复

    半个小时了还在准备安装 版本没错

  • lysnaf

    2014-10-30 01:59:48 | 回复

    不喜欢华军,捆绑了好多东西!!

  • Macl

    2014-07-21 10:58:14 | 回复

    提示安装成功,TKS!

  • www

    2014-06-25 06:40:14 | 回复

    安装一直在那里没有反应。

  • 刘宗奇

    2014-03-21 23:33:51 | 回复

    你好,请问一下你是用什么工具制作的安装包吗?我也想做一个。

    • zzy

      2014-03-27 19:23:08 | 回复

      Visual Studio

  • imkunkun

    2013-10-29 23:22:47 | 回复

    老大~很喜欢你做的这个离线安装包~
    可惜现在换成了win8.1貌似版本不兼容不能用了
    能不能劳烦再弄个8.1的?谢谢啦~

  • allen

    2013-09-10 21:51:40 | 回复

    请问这个安装程序能支持 Win8.1 吗?我在Win 8 下面手工处理没有成功,用你的安装包可以安装成功,能否给出一个安装脚本?或者介绍一下这个原理,谢谢!

  • wistarialuo

    2013-05-07 06:08:25 | 回复

    安装时要有原始文件么?!

    • zzy

      2015-05-02 22:06:41 | 回复

      不需要

  • nyconing

    2013-02-06 04:03:58 | 回复

    =-=做个32位的,我要反WIN8了,顺便说下,WIN8的.NETFARAMEWORK3.5是无法在线安装的

  • xyh

    2012-12-08 08:08:53 | 回复

    为什么我安装了半个小时还没安装成功。。。

    WIN8专业版。。。64位

  • xo

    2012-11-08 00:24:41 | 回复

    必须是64位的啊,我的32位win8装不了啊,能在制作一个32位的么,谢谢

  • zzy

    2012-11-03 03:45:49 | 回复

    还行吧 一般正常3-5分钟

  • king

    2012-11-02 20:33:51 | 回复

    安装好慢

Loading